Raven

Raven Pro
Raven Exhibit
Raven Lite

Raven System Requirements

Announcement

We recommend Raven Pro 1.5 over Raven Pro 1.4.

Raven Pro 1.5 has several new features, as well as many improvements and bug fixes, that are not present in Raven Pro 1.4.

 

Microsoft Windows

Raven Pro 1.5 and Raven Lite 2.0 require Windows 10, Windows 8.x (Desktop), Windows 7 SP 1, Windows Vista SP2, Windows Server 2008 R2 SP1 (64-bit), and Windows Server 2012 and 2012 R2 (64-bit). You must also have Java runtime environment (JRE) version 8 update 40 or newer installed, except in Windows 10 where you must have JRE version 8 update 51 or newer installed.

Raven Pro 1.4 requires a PC running the Windows XP Home, Windows XP, Windows Vista, Windows 7, Windows 8, Windows 8.1 or Windows 10 operating system with a processor running at 500 MHz or higher (1 GHz or higher recomended), and 256 MB of RAM. The required version of Java is automatically installed with Raven.

Raven Pro should never be installed in C:\Program Files or C:\Program Files (x86) if you want to retain full functionality.

 

Mac OS X

Raven Pro 1.5 and Raven Lite 2.0 require Mac OS X version 10.8.3 or newer. You must also have Java runtime environment (JRE) version 8 update 40 or newer installed.

Raven Pro 1.4 requires Mac OS X version 10.2.6 (Jaguar) through 10.11 (El Capitan). Raven Pro 1.4 needs a Java 1.4.1, Java 5, or Java 6 installed. When you install Raven, Raven should prompt you to install Raven 6 if it is not already installed. If you miss the prompt, you can get Java 6 from Apple.

 

Linux

Raven Pro 1.5 and Raven Lite 2.0 require 64-bit Java 8, which should run on:

Raven Pro 1.4 requires computers running Linux to have at least 256 MB of RAM (1 GB recommended) and to be configured with Sun Java 5 or Java 6. We've tested Raven Pro and Raven Lite on Ubuntu, Xubuntu, and Fedora. To get Raven Pro 1.4 to install, you need to set the permissions on the installer file to be able to execute it on your system.

 

Java

Raven is developed using the Java programming language developed by Oracle/Sun and runs within a Java virtual machine (JVM). Because Raven is written in the Java language, most of the product can run across multiple operating systems with no changes to the software. Some portions of the software require specific code to run on specific operating systems, but the bulk of the code is common.

Raven Pro 1.5 and Raven Lite 2.0 require Java 8 build 40 or later, except in Windows 10 where they require Java 8 build 51 or later (download). For Windows computers, 32-bit Raven installers require 32-bit Java 8 and 64-bit Raven installers require 64-bit Java 8.

Raven Pro 1.4 requires Java 1.4.1, Java 5 or Java 6 to be able to run. On Microsoft Windows, Raven Pro and Raven Lite installations include a copy of the Java 6.0 JVM from Oracle/Sun. Raven Pro 1.4 will be the last version of Raven Pro to run on Java 1.4, Java 5 or Java 6.

 

Notice

If you're still running Raven Pro versions prior to 1.4, we encourage you to install Raven Pro 1.4 as previous versions are no longer supported. All Raven 1.0, 1.1, 1.2, 1.2.1, and 1.3 licenses will work with 1.4, and 1.5.

Export of the Java virtual machine is not allowed to countries under US embargo. Because of this, we are not allowed to license Raven Pro or Raven Lite to users in those countries.