Raven Pro 1.5 Features

What follows below is a list of features included in Raven Pro 1.5 alpha1 and a description of how to use them. If you have questions after reading this document, please post them to the Help and Discussion forum located at http://help.RavenSoundSoftware.com/forum/.

Real Clock Times

Raven Pro 1.5 allows the user to set the start time of a sound file or sequence of sound files, and then to display the real clock time on the time axis. Previous versions of Raven would display the start of the sound as time 0 and the rest of the times as offsets from time 0. With Raven Pro 1.5, you can tell Raven to set the start date and time of the file sequence, or you can have Raven read the start date and time of each file in the file sequence, allowing you to analyze sound data that were collected from a recorder using a duty cycle, where the recorder does not record continuously but rather is turned on and off for periods of time. You can also analyze a season’s worth of data, where the recorder may have been on for different periods of time each day (as is the case when recorders are set to record from sunset to sunrise when recording night flight calls of migrating birds).

To set the start time of the file, go to the Date and Time tab on the Configure Sound Window dialog that Raven displays after you select a file or files to open.

Click on the Use clock-time axis labels to enable this feature, then choose to either enter the start time of the file or to read the start time of the file from the file name.
If you choose to have Raven read the start time of the file from the file name, you get to enter a file name template that Raven will use to parse the date and time of the start of the file from the file name. Raven uses the same template values in this dialog as it does in the recorder and in the **Save All Selections As** dialog, namely <yyyy> for year, <ll> for month, <dd> for day, <hh> for hour, <mm> for minute, and <ss> for second. Raven will assume a wildcard to the left and right of the template in the file name so you do not have to explicitly type in the fixed parts of the file names that do not contain date or time information. On the dialog, Raven will report the example start time that it is able to decipher from the template that you provide and from the first file in your list. To have Raven save this template as the template to use in the future, be sure to check the check box on the dialog.
In the time axis of the opened sound, Raven will display the clock time of the sound data instead of starting at 0 and increasing from there. In addition, when you move your mouse over the sound data, Raven will display the date and time of the sound in the status pane at the bottom of the Raven window.

If you open a sound file or sequence with the paging option, then Raven will display the date and time in the paging configuration panel at the top of the window, and you will be able to set not only the page start time as an offset from 0 (which is an existing feature of Raven), but you will also be able to set the page start time as an absolute date and time.

When a sound file or sequence continues through midnight, the clock time on the time axis will change from 23:59 to 00:00. If files in the file sequence are not contiguous in time, then the changes in time will occur at the file boundaries, which are indicated by green file separators.
Compare Selection Tables

Since Raven Pro 1.3, users have been able to run detectors within their sound files to find signals of interest. In version 1.4, we added the ability to run detectors in batch mode, meaning that a detector could be set up to run across multiple sound files or sound file sequences. In version 1.5, we’ve added the ability to compare selection tables to allow users to assess the performance of their detectors.

To prepare to compare tables, you first need to have two tables to compare. The truth table is one that you as a user would create by browsing through a section of the sound data and creating selections around signals of interest that you want a detector to find. The test table is a selection table that was created by a detector. The output table is generated by Raven if the user provides a file into which to write the table. The output table contains an annotation column called TP/FP/FN with values that indicate if selections in the test table were found in the truth table. The cell values are:

TP if the selection in the test table matches a selection in the truth table by overlapping it such that the midpoint of the time of the selection in the test table falls within the time bounds of the selection in the truth table or vice versa. In this case, the selection will be copied from the test table to the output table.

FP if the selection in the test table is not found in the truth table. In this case, the selection will be copied from the test table to the output table.

FN if the selection in the truth table is not found in the test table. In this case, the selection will be copied from the truth table into the output table.
New Playback Options

Two new playback options were added to Raven Pro 1.4 after we froze the user’s manual to disable them by default in 1.4 and allow them to be turned on by a preference. The preference defaults to true in the code in 1.5, but the default RavenPreferences.txt file that ships with Raven Pro 1.5 has it set to false.

raven.playback.paddedPlaybackControl.enabled=false

From the Edit menu, choose Preferences, then search for this preference in the file. If it is missing, then add it in and set it to true. Setting the preference to true will enable two new controls.

1) Padded playback, which tells Raven to play selections including a fixed amount of the sound before and after the selection. This provides some context of the sound to play around the selection.

2) Synched play, which tells Raven to move the current time position marker in synch with the play cursor. This is useful when a spectrogram slice view is visible because it will update the slice view with each spectrogram frame as it is being played. The downside is that playing in an active recorder while synched does not behave as it used to behave. For this reason, we have a toggle button for this feature in the user interface.

Pad Playback and Synch Playback controls on the Playback side panel.

Pad  Playback and Synch Playback toggle buttons on the Play tool bar.
Selection Review and Annotation

Raven’s Selection Review feature allows you to look through large numbers of selections at a time and to annotate them using the keyboard with as few keystrokes as possible.

Setup

1. **Configuring the thumbnail window look and feel**: Open a sound in Raven (File > Open Sound Files...).

2. **Delete the Waveform view if you don’t plan to use it in the postage stamps (thumbnails)**. This will streamline the processing when Raven has to create all of the review windows for the selections. Even when a view is hidden, it is still created, so if you don’t want it, delete it.

3. **Determine the annotation column names that you want to use**, and add them to this window. **View > Add Annotation Column**.
4. Configure the sound window to show the contents of the annotations columns that you just added.
   a. View > Configure Selection Labels
   b. From the right side, double-click on each annotation column name for which you want to see annotation values in the review windows.
   c. Press OK.

5. Configure the window to have as few window adornments showing as possible. Delete the Waveform view, turn off the following component visibilities: Axes (unless you need them), Axis Titles, Line Titles, Position Markers, Scrollbars, Selection Borders (optional), Selection Control Points, Selection Fill, Selection Table, Measurements, View Selection Buttons, Major Grid, Minor Grid.

6. Save a window preset (View > Window Preset > Save As... > thumbnail)

7. Configuring the context view: Open a longer file that you will be analyzing. Select a page size that will provide a reasonable contextual view of the data. You will use this view as a secondary view with a broader context than the thumbnails. For example, with night flight calls of birds, the calls are 100 ms long so you might choose a 1 second context page size. For Northern Right Whales, the up-call is around 1 second so you might choose 10-30 seconds for the context page size.

8. Since this will be your context view, you will not likely need to page forward and back too often in the context view. You will instead be moving through the context view by clicking on selections. For now, you can hide the paging controls by unchecking the Page Controls checkbox on the Layout tab in the side panel just to free up some space within your window.

9. To configure Selection Review, go to the Review side panel and pick the number of rows and columns along with a time pad and frequency pad that you want to be inserted around the selections for listening and viewing.

10. The Time Scale and Frequency Scale options allow you to zoom in on every selection even if you want to listen to a wider context. Setting a time pad and setting the time scale to Selection will allow full spectrograms.
without gray “no data” areas. If you would like to see a constant time scale for all selections, then use the third (unnamed) time scale option, which allows you to set a fixed time scale across all selection review windows. Similarly, frequency scale can be set to the selection, to the pad, or to a constant value.

11. Time Start and Frequency Start allow the user to specify where the review window will start showing the selection, either zoomed to the selection boundaries (Selection), zoomed out to include the padding (Pad), or starting at a fixed frequency (the third option for Freq Start). These allow users to see a consistent view of the selections.

12. The Play option allows you to listen to either the visible section of the sound or the full (padded) sound. Some users would like to see the zoomed in section of the selection but play a wider context. You can do this by setting a time pad but zooming in to the selection, then using the play full option.

13. The Context checkbox allows users to see the context of the selection in the broader context of the parent sound window. All options described previously require the user to press the Apply button to have the change processed. The context control is unique in that it will apply immediately, shrinking the area for the thumbnails to allow room for the parent window to be shown at the top of the Raven window. Note that the context window is a regular sound window with all of the controls that you’re used to seeing in Raven, but when the window becomes a context window, you are no longer able to move or resize it.

14. The Size control allows the user to specify the height or width in pixels of the context window. This control is also applied immediately when the Enter key is pressed within the control, when the tab key is pressed to move to another control, or when another control gets focus.

15. The Location radio buttons allow the user to pick whether the context window appears at the left end of the Raven window or at the top of the Raven window. Users with single-channel data might choose top, whereas users with multi-channel data might choose left to be able to clearly see all channels of audio in the context window.

16. The View control allows users to switch between looking at thumbnails and seeing the selection
table with all of its cells. This is done by first configuring the parent window to have the selection table open to the desired size, then hiding the selection table using the Layout side panel, then pressing the Apply button on the Review panel to engage the thumbnails. Once the thumbnails are showing, the user can toggle between seeing the thumbnails and the table. It sometimes takes a couple of toggles between thumbnail and table to get this working. Note also that this feature was created when we only had the ability to set the context window to the top of the Raven window. Having the context window at the left side and toggling back and forth is not as useful at the moment.

17. The **Preset** control is a similar control to what users may remember seeing on the Configure Sound Window dialog in that it allows users to select the preset that gets applied, but in this case, the preset is the one applied to the selection review windows, not the parent window. The default preset for selection review windows is specified in RavenPreferences.txt. An example is listed below.

```
raven.preset.soundWindow.defaultSelectionWindowPreset=ZoomNoScale
```

Even without having the preference set, users can pick a preset to apply to the thumbnail windows. To change the preset that is applied to all thumbnails, pick a new one and press the apply button. To change an existing preset, change the look of a single thumbnail, then save the preset (right click on the thumbnail and choose Window Preset > Save As...). To apply this saved preset to all thumbnails, press the apply button or press Enter when one of the thumbnails is in focus (has a red border).

18. The **Sound** control allows the user to specify which of the open sound windows will be loaded into the selection review feature. As new windows are opened, this combo dropdown box is updated to contain all open sounds. The user must press the Apply button to update to the latest input parameters.

19. The **Table** control allows the user to pick the selection table from which to view selections. As new tables are added to the window or new windows are opened, the values in this control change. The user must press the Apply button to update to the latest input parameters.

20. The **Filter** control allows the user to pick a single annotation column to use as the filter for annotations. The **Show** control is a combination of a checkbox and text field that is used with the Filter control. If the Show box is checked, then Raven will look in the specified annotation column and only show selections whose annotation values match the one listed in the text
field. If the Show text field is left empty, then only selections with empty annotations in that column will be shown.

21. The **Annotate** control is used in some situations to add annotations to a specific annotation column. The user selects the column, and then uses keystrokes to annotate the selections. Raven allows users to set up a predefined set of keys that are mapped to values or to use any key as a single key value to be stored in the annotation column. To disable unmapped keys from being used and thus preserve using a predefined annotation vocabulary, the preference below must be set.

Example preference to prevent unmapped keys from being used to set annotation values. The default if not set is true, which allows any key to be used.

```raven
raven.annotation.keyMap.useUnmappedKeys=false
```

22. The **Start** control tells Raven in what row to start looking in the selection table for selections. Note that you can sort the selection table using any column, and then apply changes to the review feature to see selections displayed in the desired order.

**Buttons:**

- ![Apply](image) Apply the parameters
- ![Undo](image) Undo changes, revert to previous
- ![Close](image) Close all selection review window.
- ![Go](image) Go to previous or next selections
Selection Review Windows

When you press the Apply button, Raven first creates the selection review windows, and then it fills them. A progress dialog will let you know how long you have to wait.

Examples:

**Figure 1:** 10 rows by 20 columns showing thumbnails with context view.

**Figure 2:** Table view.
Figure 3: 10 rows by 20 columns using a custom preset.

**Mouse cursor settings**

The following settings are set up for the mouse, used in conjunction with the keyboard.

Click in a review window: marks that window as the single marked window.

Double-click in a review window: play the sound.

Click in a review window that's playing: stops the playback.

Ctrl/Command-click: add the clicked review window to the marked set.

Shift-click: add all review windows between the last selected window and the clicked window to the marked set.

Right-click: show the default context-sensitive menu.

**Default key mappings**

These key mappings are defined when the selection review windows have focus. You'll know that they have focus if any of the review windows have either a red or green border (two pixels wide).
Left arrow: Move left one review frame, wrapping around the left side of each row and back to a previous page of thumbnails from the top left corner.

Right arrow: Move right one review frame, wrapping around the right side of each row and to the next page of thumbnails from the bottom right corner.

Up arrow: Move up one review frame, wrapping around from top to bottom and one column to the left, and to the previous page from the top left corner.

Down arrow: Move down one review frame, wrapping around from bottom to top and one column to the right, and to the next page from the bottom right corner.

Ctrl-Left arrow, Ctrl-Up arrow: Go to previous page of thumbnails.

Ctrl-Right arrow, Ctrl-Down arrow: Go to next page of thumbnails.

Shift key + direction arrow: extend the currently marked set of review windows to include the next one. The border of the current review frame will be red, and all others in the marked set will be black.

Shift key + Alt key + direction arrow: change the currently selected review frame to the one in that direction, but do not add the new frame to the marked set (will be green border).

Figure 4: 4 review windows in a market set, including the red (left) and not including the green (right).

Space bar: play current review frame, or stop if playing.

Enter key: refresh the page of thumbnails using the current Start selection number.

Delete, Backspace: clear selection border of currently marked set. There is a warning dialog that is shown to prevent the user losing data.

Ctrl-Plus: Expand current review frame to the size of the Raven desktop.

Ctrl-Minus: Retract current review frame back to its original location.

Ctrl-A: Mark all selection review windows for action.

Ctrl-I: Invert the marked set.
Ctrl-/ (slash): Hide or show the Raven menu bar. This can be useful for two reasons: (1) it provides more screen real estate for review, (2) on some platforms, it disables the keyboard accelerators on the menus.

Ctrl-] (close bracket): switch to table mode (identical to clicking the Table control on the side panel.

More on Annotations

If you have the following line in RavenPreferences.txt (Edit > Preferences), then you will also be able to annotate using single keystrokes. True is the default so you can leave this line out and still be able to annotate with single keys.

raven.annotation.keyMap.useUnmappedKeys=true

For a single selection, pressing a key will store that key’s value in the annotation column that’s specified in the Annotate control on the side panel. If multiple review frames are marked (using either keys or mouse), then all review windows within that set will be annotated with that key value.

Holding down the Alt key (also called the Option key on Macs) and pressing a key will cause all review windows to store that key value as an annotation for that column. Be careful because if the Raven menu is showing, then in addition to getting the desired effect of annotating all review windows, you will also get the added effect of showing a Raven menu if you use Alt plus F, E, V, W, T, or H. To get around this, you can hide the Raven menu bar using Ctrl-/.

Setting up key mappings for annotations

Raven will allow you to configure preferences to enable a single keystroke to map to one annotation value per column for as many columns as your selection table has.

raven.annotation.keyMap.<N>=<key>,<column1>:<value1>,<columnX>:<valueX>

where...

N = a number starting with 1 and increasing through the preferences file until it reaches a max value specified by a separate preference: raven.annotation.keyMap.maxKeys=M. This would allow gaps so users could create a set of keys and then comment out lines for whatever reason without having to redo any of the other keyMap preferences.

<key> = a number or letter (lower or upper case), but probably not special characters unless people have a strong desire for them, such that when you press this key within the selection review windows, ALL of the column/value pairs are set for the single selection or marked set of selections.
<column1> = the name of an annotation column

<value1> = the annotation value to be used in this column for this or these selections/events – blanks could be allowed within the annotation value, but blanks will be stripped off either end. For interoperability with XBAT, people in the building should not use blanks within annotation values.

Note that the users can determine how to map the keys and how many columns to use for every key. Here’s an example from RavenPreferences.txt:

First, tell Raven how high to look for key mappings. The default is 62.

\texttt{raven.annotation.keyMap.maxKeys=36}

The next two examples allow for simple annotations (one column).

\texttt{raven.annotation.keyMap.1=n,type:noise}
\texttt{raven.annotation.keyMap.2=c,type:call}

The preferences listed in 3-6 allow annotation of two columns with a single keystroke.

\texttt{raven.annotation.keyMap.3=t,type:call,complex:tseep}
\texttt{raven.annotation.keyMap.4=b,type:call,complex:warble}
\texttt{raven.annotation.keyMap.5=p,type:call,complex:ping}
\texttt{raven.annotation.keyMap.6=g,type:call,complex:pingg}

Items 7-12 show three annotations are possible with a single keystroke. Note that you can map lower and upper case letters to different annotations (10, 11). You can also define lower and upper case letters to map to the same annotations.

\texttt{raven.annotation.keyMap.7=h,type:call,complex:tseep,species:HETH}
\texttt{raven.annotation.keyMap.8=w,type:call,complex:tseep,species:WOTH}
\texttt{raven.annotation.keyMap.9=s,type:call,complex:tseep,species:SWTH}
\texttt{raven.annotation.keyMap.10=v,type:call,complex:warble,species:VEER}
\texttt{raven.annotation.keyMap.11=V,type:call,complex:warble,species:VATH}
\texttt{raven.annotation.keyMap.12=z,type:call,complex:ping,species:ZEFI}

Items 13 and 33-36 show that you don’t always need to use 3 annotations.

\texttt{raven.annotation.keyMap.13=x,species:UNKNOWN}
\texttt{raven.annotation.keyMap.33=1,type:call,species:bowhead}
\texttt{raven.annotation.keyMap.34=2,type:call,species:blue}
\texttt{raven.annotation.keyMap.35=3,type:call,species:fin}
\texttt{raven.annotation.keyMap.36=4,type:call,species:UNKNOWN}
Notes on the examples:

1. We could use both lowercase and uppercase letters for keys, but this might not be practical since most people will not want to hold down the shift key when annotating. I suppose they could have the caps lock key on or use the shift key for less common annotations.

2. We will not be using the equals sign between column:value pairs because the equals sign separates the preference from its value. This may take a little while to get used to.

3. On key 13, there is no mapping to call or complex, only to species. This is shown to let you know that it’s allowed, but your protocol might not include choices like this.

4. Keys 33-36 show that you can have mappings for different protocols in the same session of Raven. Whale analysts might only use type and species without a column for complex.

5. What seems to work well here is that in a single pass, if you know multiple annotations to set for a single event, then you can do it. In previous thoughts about this, I had figured that users would need to make multiple passes to fully annotate a recording. For advanced users, they may be able to get through in one pass.

6. The ALT key is the current modifier to allow you to set all events on a page of thumbnails to a single value. This will still work with a set of column:value pairs. For example, ALT+N would mark everything as noise, whereas ALT+W would mark everything as a Wood Thrush. Keys to avoid with ALT are those that are mapped to Raven menus (F, E, V, W, T, H). These still work as annotation values, but they currently pop open the menu as well. You might choose to map these to less common species that would not normally be used with ALT, or you might have to use the Ctrl-M keys to hide the menu while you’re in selection review mode.

At some point, we can probably add a modeless dialog that displays all of the key mappings. It would be modeless so the user can have it open while doing other things in Raven. Initially, it might be a good idea to write down the mappings on paper or in a spreadsheet, or to keep the preferences file open. Also, I would not plan to add any user interface in the short term to allow users to set, edit, or remove key maps. The initial work would be to get something up and running and in use.

For any key that was not mapped to a collection of column:value pairs, the key would map to itself as a single key annotation value. Currently, I use uppercase characters when the keys are pressed, but I could look into using both upper and lower case versions. If a user wanted to use a strict language of possible values for annotation, then the user could turn off the use of straight keys as single character annotation values with the following preference, which would default to true. This is not implemented yet.

```raven.annotation.keyMap.useUnmappedKeys=false```

Perhaps we could make that one a checkbox in the user interface. If an unmapped
key was used, then Raven would look at the currently chosen annotate column in the side panel, and it would store that key character in that column as an annotation value. This may not make sense to those who have not run with the new Raven.

Note that I’m not considering changing any of the annotation cell processing in the selection table. All of this is just for the selection review windows.

**Related Enhancements**

In order to gain more Raven desktop space quickly, we added new menu items on the View > Tool Bars menu for hiding and showing all tool bars.

In the Layout tab of the side panel, in the Components section, there is now a control for Page Controls so you can hide these controls and save a lot of space in your paged sound window.

When new selections are added to the selection table, they show up in the review thumbnails. It may take a refresh (Enter) for them to appear, but they should show up.

When selections are cleared (removed), the review windows should be immediately updated to reflect that they’re gone.

When Raven is processing a review window refresh or page forward/back, the currently selected review window will change its border from red to green. Once the processing is completed, the red border should return to one of the review windows, but not necessarily to the same one.